The AWS incident ended at 7:00 PM ET on 10/20 and all Scholastic applications and services have been restored.
Posted Oct 21, 2025 - 09:49 EDT
Update
Scholastic services are currently recovering, with most systems operational. AWS continues to report intermittent network connectivity issues, indicating the situation is improving but not yet fully resolved. We will continue to monitor AWSs progress and the status of our applications.
Posted Oct 20, 2025 - 16:15 EDT
Monitoring
AWS is reporting degraded performance for multiple services that may be used by our applications. We are continuing to monitor the ongoing the outage and identify systems that are impacted.
Posted Oct 20, 2025 - 13:04 EDT
Update
We're currently seeing issues with Classlink due to the AWS Outage. We are still investigating if other services are impacted and are monitoring the AWS status page for updates.
Posted Oct 20, 2025 - 10:05 EDT
Investigating
There's currently a widespread AWS outage that might be impacting Scholastic services. We're currently investigating to determine impact.