Data processing for FIRST on the Scholastic Dashboards

Incident Report for Scholastic Digital

Resolved

The issue has been resolved and all data is now up to date on the Scholastic Dashboards.
Posted Feb 26, 2026 - 11:00 EST

Identified

The data processing has been restored. Some data will need to be reprocessed going back to 2/11. The exact timeline to reprocess that data is still being determined.
Posted Feb 23, 2026 - 13:16 EST

Investigating

We are investigating an issue with data processing for FIRST. Dashboard data may be missing for the past several days.
Posted Feb 23, 2026 - 11:08 EST
This incident affected: Teacher and Administrator Dashboards.