Clever outage effecting access to Scholastic products.
Incident Report for Scholastic Digital
Resolved
Clever has resolved the Portal issues. Users experiencing issues accessing Scholastic applications through Clever should be be able to log in without issue.
Posted Sep 13, 2023 - 11:21 EDT
Monitoring
Clever is currently experiencing an outage with the Clever Portal. Customers who access Scholastic applications through Clever single sign-on are currently unable to login. We are monitoring the outage with Clever and will provide updates as they are available. Customers who access Scholastic applications directly through digital.scholastic.com or any of our other third party integrations are unaffected.
Posted Sep 13, 2023 - 10:43 EDT
This incident affected: Scholastic Digital Manager.