Knowledge Library Failing to Launch

Incident Report for Scholastic Digital

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 11:16 EDT

Update

As of this time, Knowledge Library is back online. The root cause was an errant deployment, which has been rolled back. No further downtime is expected.
Posted Sep 02, 2026 - 11:15 EDT

Update

We are continuing to investigate this issue.
Posted Sep 02, 2026 - 10:41 EDT

Investigating

We're currently receiving reports that Knowledge Library is failing to launch from the Scholastic Education Platform for all customers. Scholastic's engineering teams are currently investigating the issue and will update with resolution timelines when available.
Posted Sep 02, 2026 - 10:41 EDT