Security Certificate Issue

Incident Report for Scholastic Digital

Resolved

The certificate has been updated, and W.O.R.D. should be working as expected. It may take some time depending on the user's cache settings for the new certificate to be recognized.
Posted Jan 12, 2026 - 13:42 EST

Investigating

The Security Certificate has expired for W.O.R.D.. Customers will get a certificate error. The team is working to restore the security certificate.
Posted Jan 12, 2026 - 13:03 EST
This incident affected: W.O.R.D.