Clever Portal not loading for Students and Teachers

Incident Report for Scholastic Digital

Resolved

This incident has been resolved.
Posted Oct 15, 2025 - 16:05 EDT

Update

Clever has implemented a fix and we are monitoring the results. Service should be restored for all users.
Posted Oct 15, 2025 - 15:09 EDT

Monitoring

Clever is experiencing an issue with wide-spread reports of the Portal not loading for Students and Teachers. In the meantime, users should be able to access their learning applications by going directly to the application and using the "Sign in with Clever" option.

Clever is investigating the issue and will provide regular status updates. https://status.clever.com/
Posted Oct 15, 2025 - 13:46 EDT