Temporary Dashboard Data Delay for WORD, FIRST, and NSGRA

Incident Report for Scholastic Digital

Update

The team continues to work to reprocess the missing report data.
Posted Sep 16, 2025 - 15:17 EDT

Identified

We’re currently experiencing a delay in processing data for the Teacher and Administrator dashboards. Data sent between 3:32 PM and 7:36 PM Eastern Time for NSGRA, WORD, and FIRST assessments on 9/15/2025 was not processed as expected.

- No data has been lost — it’s safe and intact.
- Our team is actively working to reprocess the affected data so it appears correctly in your dashboards.

We appreciate your patience and will update you once the issue is resolved.
Posted Sep 16, 2025 - 10:15 EDT
This incident affects: Teacher and Administrator Dashboards, F.I.R.S.T, and W.O.R.D.