Grades K, 3, and 5 impacted for Knowledge Library

Incident Report for Scholastic Digital

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 18:17 EDT

Investigating

Users in grades K, 3, and 5 are unable to load content in Knowledge Library. The issue seems to be isolated to users with content assigned to a single grade. Scholastic's engineering teams are investigating.
Posted Sep 02, 2026 - 13:26 EDT